summary refs log tree commit diff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2020-09-17 09:50:10 +0530
committerArun Isaac <arunisaac@systemreboot.net>2020-10-12 11:41:46 +0530
commit3688b52426375534b9a4ef38910b58563371189c (patch)
tree4561a9a0e66e64dc9ed45a0ea04c91fc2af682db
parente12feea37cc95f17362c0d0065824c2f3d92e0f4 (diff)
downloadguix-3688b52426375534b9a4ef38910b58563371189c.tar.gz
gnu: Add rust-webpki-roots.
* gnu/packages/crates-io.scm (rust-webpki-roots-0.20, rust-webpki-roots-0.19):
New variable.
(rust-webpki-roots-0.18): Inherit from rust-webpki-roots-0.19.
-rw-r--r--gnu/packages/crates-io.scm45
1 files changed, 38 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 02bbf89f3b..c7215ad6fa 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -28276,25 +28276,56 @@ Verification.")
        #:cargo-development-inputs
        (("rust-base64" ,rust-base64-0.9))))))
 
-(define-public rust-webpki-roots-0.18
+(define-public rust-webpki-roots-0.20
   (package
     (name "rust-webpki-roots")
-    (version "0.18.0")
+    (version "0.20.0")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "webpki-roots" version))
-      (file-name (string-append name "-" version ".tar.gz"))
-      (sha256
-       (base32 "1d4ss607rgi9pj01zzqa13c1p3m35z314yh6lmjaj4kzvwv5gkci"))))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "17qpmyym1lsi967b4nc3112nb13ism8731bhjqd9hlajafkxw80g"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:cargo-inputs (("rust-webpki" ,rust-webpki-0.21))))
+     `(#:cargo-inputs
+       (("rust-webpki" ,rust-webpki-0.21))))
     (home-page "https://github.com/ctz/webpki-roots")
     (synopsis "Mozilla's CA root certificates for use with webpki")
-    (description "Mozilla's CA root certificates for use with webpki")
+    (description "This package provides Mozilla's CA root certificates for use
+with webpki.")
     (license license:mpl2.0)))
 
+(define-public rust-webpki-roots-0.19
+  (package
+    (inherit rust-webpki-roots-0.20)
+    (name "rust-webpki-roots")
+    (version "0.19.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "webpki-roots" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0fapdqwbfv0kncplpvbgnr0bjd5a9krlpij9jdzk0mvaa6vz9vzq"))))))
+
+(define-public rust-webpki-roots-0.18
+  (package
+    (inherit rust-webpki-roots-0.19)
+    (name "rust-webpki-roots")
+    (version "0.18.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "webpki-roots" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1d4ss607rgi9pj01zzqa13c1p3m35z314yh6lmjaj4kzvwv5gkci"))))))
+
 (define-public rust-webpki-roots-0.17
   (package/inherit rust-webpki-roots-0.18
     (name "rust-webpki-roots")