summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-09-26 11:39:26 -0400
committerLeo Famulari <leo@famulari.name>2017-09-26 11:42:06 -0400
commit373cda6ac6293d2aa5273ac28a505a2f0beb09dc (patch)
tree6c53ff07e4870d02e300c31cd68f3baa98cbc24b
parent8fd92e034bbc6675df6890713a1e5907ab53af38 (diff)
downloadguix-373cda6ac6293d2aa5273ac28a505a2f0beb09dc.tar.gz
gnu: libunwind: Update to 1.2.1.
* gnu/packages/libunwind.scm (libunwind): Upate to 1.2.1.
[source]: Remove 'libunwind-CVE-2015-3239.patch'.
* gnu/packages/patches/libunwind-CVE-2015-3239.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/libunwind.scm8
-rw-r--r--gnu/packages/patches/libunwind-CVE-2015-3239.patch17
3 files changed, 4 insertions, 22 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 12a6681544..bf03472519 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -811,7 +811,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/libtirpc-CVE-2017-8779.patch		\
   %D%/packages/patches/libtorrent-rasterbar-boost-compat.patch	\
   %D%/packages/patches/libtool-skip-tests2.patch		\
-  %D%/packages/patches/libunwind-CVE-2015-3239.patch		\
   %D%/packages/patches/libunistring-gnulib-multi-core.patch	\
   %D%/packages/patches/libusb-0.1-disable-tests.patch		\
   %D%/packages/patches/libvpx-CVE-2016-2818.patch		\
diff --git a/gnu/packages/libunwind.scm b/gnu/packages/libunwind.scm
index cda83b2bc0..e747d37787 100644
--- a/gnu/packages/libunwind.scm
+++ b/gnu/packages/libunwind.scm
@@ -27,18 +27,18 @@
 (define-public libunwind
   (package
     (name "libunwind")
-    (version "1.1")
+    (version "1.2.1")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://savannah/libunwind/libunwind-"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "16nhx2pahh9d62mvszc88q226q5lwjankij276fxwrm8wb50zzlx"))
-             (patches (search-patches "libunwind-CVE-2015-3239.patch"))))
+               "1jsslwkilwrsj959dc8b479qildawz67r8m4lzxm7glcwa8cngiz"))))
     (build-system gnu-build-system)
     (arguments
-     ;; FIXME: As of glibc 2.17, we get 3 out of 34 test failures.
+     ;; FIXME: As of glibc 2.25, we get 1 out of 34 test failures (2 are
+     ;; expected to fail).
      ;; Report them upstream.
      '(#:tests? #f))
     (home-page "http://www.nongnu.org/libunwind")
diff --git a/gnu/packages/patches/libunwind-CVE-2015-3239.patch b/gnu/packages/patches/libunwind-CVE-2015-3239.patch
deleted file mode 100644
index 3f11ac7337..0000000000
--- a/gnu/packages/patches/libunwind-CVE-2015-3239.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Copied from Fedora.
-
-https://bugzilla.redhat.com/show_bug.cgi?id=1232265
-http://pkgs.fedoraproject.org/cgit/libunwind.git/tree/libunwind-1.1-fix-CVE-2015-3239.patch
-
-diff -up libunwind-1.1/include/dwarf_i.h.CVE20153239 libunwind-1.1/include/dwarf_i.h
---- libunwind-1.1/include/dwarf_i.h.CVE20153239	2015-07-10 13:38:36.404996748 -0400
-+++ libunwind-1.1/include/dwarf_i.h	2015-07-10 13:39:25.050707613 -0400
-@@ -20,7 +20,7 @@
- extern const uint8_t dwarf_to_unw_regnum_map[DWARF_REGNUM_MAP_LENGTH];
- /* REG is evaluated multiple times; it better be side-effects free!  */
- # define dwarf_to_unw_regnum(reg)					  \
--  (((reg) <= DWARF_REGNUM_MAP_LENGTH) ? dwarf_to_unw_regnum_map[reg] : 0)
-+  (((reg) < DWARF_REGNUM_MAP_LENGTH) ? dwarf_to_unw_regnum_map[reg] : 0)
- #endif
- 
- #ifdef UNW_LOCAL_ONLY