summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-11-27 20:38:42 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-11-30 15:50:09 +0100
commit3a23b461f4eea3f0bd4e54018bc886d9db70017a (patch)
tree437a123341d1d4f35e9bfa7aca1dcf832a7ca9d1
parent8146ec55589d0e8967fca6325fcee60f9efd40ab (diff)
downloadguix-3a23b461f4eea3f0bd4e54018bc886d9db70017a.tar.gz
gnu: lablgtk: Update to 2.18.8.
* gnu/packages/ocaml.scm (lablgtk): Update to 2.18.8.
[source]: Use git-fetch.
[native-inputs]: Remove camlp4.
-rw-r--r--gnu/packages/ocaml.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 4a6cec4bd9..dea01cf6ad 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -814,17 +814,18 @@ Knuth’s LR(1) parser construction technique.")
 (define-public lablgtk
   (package
     (name "lablgtk")
-    (version "2.18.6")
+    (version "2.18.8")
     (source (origin
-              (method url-fetch)
-              (uri (ocaml-forge-uri name version 1726))
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/garrigue/lablgtk")
+                     (commit "lablgtk2188")))
               (sha256
                (base32
-                "1y38fdvswy6hmppm65qvgdk4pb3ghhnvz7n4ialf46340r1s5p2d"))))
+                "0gpww8bkwi5cl68kc006970zvzwvq73h1mwrnd239apmwlxc1l8a"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("camlp4" ,camlp4)
-       ("ocaml" ,ocaml)
+     `(("ocaml" ,ocaml)
        ("findlib" ,ocaml-findlib)
        ("pkg-config" ,pkg-config)))
     ;; FIXME: Add inputs gtkgl-2.0, libpanelapplet-2.0, gtkspell-2.0,