summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 09:58:45 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:04 -0500
commit3ad67f6b3a84c9e02dc21bbf653b55160f40dade (patch)
tree5293ee97183be557904d8275024e983a92e7e497
parent74bf69651dcbc03db6173cf841fd38a8a7d331ec (diff)
downloadguix-3ad67f6b3a84c9e02dc21bbf653b55160f40dade.tar.gz
gnu: ghc-vector: Update to 0.12.0.3.
* gnu/packages/haskell-xyz.scm (ghc-vector): Update to 0.12.0.3.
[arguments]: Remove '#:cabal-revision'.
-rw-r--r--gnu/packages/haskell-xyz.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index c98050be11..ad0383c793 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -11298,7 +11298,7 @@ representing a store for a single element.")
 (define-public ghc-vector
   (package
     (name "ghc-vector")
-    (version "0.12.0.1")
+    (version "0.12.0.3")
     (outputs '("out" "doc"))
     (source
      (origin
@@ -11309,14 +11309,12 @@ representing a store for a single element.")
              ".tar.gz"))
        (sha256
         (base32
-         "0yrx2ypiaxahvaz84af5bi855hd3107kxkbqc8km29nsp5wyw05i"))))
+         "1a756s4w759ji3als5alfxwlckh5zcmykfg9rll4mlr2knzvz8mq"))))
     (build-system haskell-build-system)
     ;; FIXME: To simplify upgrading all Haskell packages, we leave the tests
     ;; disabled for now.
     (arguments
-     `(#:cabal-revision
-       ("3" "0y5rh8k710i2a3p1h2rghvr5cfg78p5h0kbfi7ifxqqf6pzlyr1x")
-       #:tests? #f))
+     `(#:tests? #f))
     (inputs
      `(("ghc-primitive" ,ghc-primitive)
        ("ghc-random" ,ghc-random)