summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-07 13:24:23 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-07 13:38:01 +0100
commit3b296475bf6a54fc973cb11695427fee9ec3dcab (patch)
tree1c7db5d4f2fab5598f4517e2f4f94f530a9156f1
parent237ee6f2b26ebb15a55dccd32f0feba25848e84c (diff)
downloadguix-3b296475bf6a54fc973cb11695427fee9ec3dcab.tar.gz
gnu: cd-hit: Support longer sequences.
* gnu/packages/bioinformatics.scm (cd-hit)[arguments]: Pass MAX_SEQ to make
flags.
-rw-r--r--gnu/packages/bioinformatics.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c0e4628a64..2a7d334b19 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1770,7 +1770,9 @@ high-throughput sequencing data – with an emphasis on simplicity.")
      `(#:tests? #f ; there are no tests
        #:make-flags
        ;; Executables are copied directly to the PREFIX.
-       (list (string-append "PREFIX=" (assoc-ref %outputs "out") "/bin"))
+       (list (string-append "PREFIX=" (assoc-ref %outputs "out") "/bin")
+             ;; Support longer sequences (e.g. Pacbio sequences)
+             "MAX_SEQ=60000000")
        #:phases
        (modify-phases %standard-phases
          ;; No "configure" script