summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-09-01 13:25:51 +0200
committerMarius Bakke <marius@gnu.org>2020-09-22 18:41:55 +0200
commit3be81c85cfa9185447bb47d9e35dd7c93f87407b (patch)
treed1813ebbd101aad36081105821fc2a5c643b0c0a
parent074400543dac58a43ced35b4ccee7bfa1b52dcf1 (diff)
downloadguix-3be81c85cfa9185447bb47d9e35dd7c93f87407b.tar.gz
gnu: python-django-contact-form: Update to 1.8.1.
* gnu/packages/django.scm (python-django-contact-form): Update to 1.8.1.
[arguments]: Adjust test invokation, drop flake8 checks.
[native-inputs]: Remove PYTHON-FLAKE8.
-rw-r--r--gnu/packages/django.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 0b31d5745d..f654f2d596 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -737,26 +737,26 @@ project aims to bulk update given objects using one query over Django ORM.")
 (define-public python-django-contact-form
   (package
     (name "python-django-contact-form")
-    (version "1.3")
+    (version "1.8.1")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "django-contact-form" version))
               (sha256
                (base32
-                "0az590y56k5ahv4sixrkn54d3a8ig2q2z9pl6s3m4f533mx2gj17"))))
+                "1zv7bcjfrg32gcsq3bclkld79l6mcy2wcvlj81h7q2ppv1wm8vqs"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
            (lambda _
-             ;; the next version will need "make test"
-             (invoke "flake8" "contact_form")
-             (invoke "coverage" "run" "contact_form/runtests.py")
-             (invoke "coverage" "report" "-m" "--fail-under" "0"))))))
+             (setenv "PYTHONPATH"
+                     (string-append "./build/lib:"
+                                    (getenv "PYTHONPATH")))
+             (invoke "coverage" "run" "--source" "contact_form"
+                     "runtests.py"))))))
     (native-inputs
-     `(("python-coverage" ,python-coverage)
-       ("python-flake8" ,python-flake8)))
+     `(("python-coverage" ,python-coverage)))
     (propagated-inputs
      `(("python-django" ,python-django)))
     (home-page "https://github.com/ubernostrum/django-contact-form")