summary refs log tree commit diff
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2022-08-22 09:54:36 +0000
committerJulien Lepiller <julien@lepiller.eu>2022-08-24 18:21:12 +0200
commit3d403f56dd52a46e0ca119a67552e82896aee3b4 (patch)
tree9c4433f2cd5e8e59f6f75e2046ff27e7d60710bb
parent6256e267da0e134e76364cc28b6b397ecdf4e74f (diff)
downloadguix-3d403f56dd52a46e0ca119a67552e82896aee3b4.tar.gz
gnu: Add ocaml-pprint.
* gnu/packages/ocaml.scm (ocaml-pprint): New variable.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/ocaml.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index bb1d952bb8..3572b36881 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8595,6 +8595,31 @@ Using this package, you can run afl-fuzz in ``persistent mode'', which avoids
 repeated forking and is much faster.")
     (license license:expat)))
 
+(define-public ocaml-pprint
+  (package
+    (name "ocaml-pprint")
+    (version "20220103")
+    (home-page "https://github.com/fpottier/pprint")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "09y6nwnjldifm47406q1r9987njlk77g4ifqg6qs54dckhr64vax"))))
+    (build-system dune-build-system)
+    (synopsis "OCaml pretty-printing combinator library and rendering
+engine")
+    (description "This OCaml library offers a set of combinators for building
+so-called documents as well as an efficient engine for converting documents to
+a textual, fixed-width format.  The engine takes care of indentation and line
+breaks, while respecting the constraints imposed by the structure of the
+document and by the text width.")
+    (license license:lgpl2.0)))
+
 (define-public ocaml-bibtex2html
   (package
     (name "ocaml-bibtex2html")