summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-06-26 23:39:31 +0200
committerLudovic Courtès <ludo@gnu.org>2015-07-03 15:28:06 +0200
commit3f289db69d8e3a75fb0beab4606c350133b8ace3 (patch)
treea36f0852f9f70e5e1503b1a39f83c3c657d75c38
parentb5b08878b662a856117accb2df3c6c79d646bb14 (diff)
downloadguix-3f289db69d8e3a75fb0beab4606c350133b8ace3.tar.gz
gnu: mysql: Strip references and GCC and other build-time dependencies.
* gnu/packages/databases.scm (mysql)[arguments]: Add 'strip-extra-references'
  phase.
-rw-r--r--gnu/packages/databases.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 3ab2fcdcf3..5185e3ee7f 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -133,7 +133,19 @@ SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
          "-DINSTALL_SHAREDIR=share/mysql"
          ;; Get rid of test data.
          "-DINSTALL_MYSQLTESTDIR="
-         "-DINSTALL_SQLBENCHDIR=")))
+         "-DINSTALL_SQLBENCHDIR=")
+       #:phases (modify-phases %standard-phases
+                  (add-after
+                   'install 'strip-extra-references
+                   (lambda* (#:key outputs #:allow-other-keys)
+                     ;; Strip references to GCC and other build-time
+                     ;; dependencies.
+                     (let ((out (assoc-ref outputs "out")))
+                       (for-each remove-store-references
+                                 (list (string-append out "/bin/mysqlbug")
+                                       (string-append
+                                        out "/share/mysql/docs/INFO_BIN")))
+                       #t))))))
     (native-inputs
      `(("bison" ,bison)
        ("perl" ,perl)))