summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-12-24 09:53:07 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-12-24 10:10:40 +0100
commit409be57b091e6cb8cb19e668eac09832caa780de (patch)
treeafffae7f940ca91480259878ec1a9cb97d78cbb9
parentc493679f9a1000049f81d74b9220aac566ba11ac (diff)
downloadguix-409be57b091e6cb8cb19e668eac09832caa780de.tar.gz
gnu: lilypond: Build info pages with images.
* gnu/packages/music.scm (lilypond)[arguments]: Set "conf" and "out" to
  "www"; rename phase "hardcode-path-to-gs" to "fix-path-references";
  fix reference to "/bin/sh"; add phase "install-info".
-rw-r--r--gnu/packages/music.scm25
1 files changed, 16 insertions, 9 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 14590f4e22..8ae9bc0aa8 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -268,27 +268,34 @@ you to define complex tempo maps for entire songs or performances.")
     (arguments
      `(#:tests? #f ; out-test/collated-files.html fails
        #:out-of-source? #t
+       #:make-flags '("conf=www") ;to generate images for info manuals
        #:configure-flags
-       (list (string-append "--with-texgyre-dir="
+       (list "CONFIGURATION=www"
+             (string-append "--with-texgyre-dir="
                             (assoc-ref %build-inputs "font-tex-gyre")
                             "/share/fonts/opentype/"))
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'hardcode-path-to-gs
-          (lambda* (#:key inputs #:allow-other-keys)
+         (add-after 'unpack 'fix-path-references
+          (lambda _
             (substitute* "scm/backend-library.scm"
               (("\\(search-executable '\\(\"gs\"\\)\\)")
-               (string-append "\""
-                              (assoc-ref inputs "ghostscript")
-                              "/bin/gs"
-                              "\"" )))
+               (string-append "\"" (which "gs") "\""))
+              (("\"/bin/sh\"")
+               (string-append "\"" (which "sh") "\"")))
             #t))
          (add-before 'configure 'prepare-configuration
           (lambda _
             (substitute* "configure"
               (("SHELL=/bin/sh") "SHELL=sh"))
-            (setenv "out" "")
-            #t)))))
+            (setenv "out" "www")
+            (setenv "conf" "www")
+            #t))
+         (add-after 'install 'install-info
+           (lambda _
+             (zero? (system* "make"
+                             "-j" (number->string (parallel-job-count))
+                             "conf=www" "install-info")))))))
     (inputs
      `(("guile" ,guile-1.8)
        ("font-dejavu" ,font-dejavu)