summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-11-21 00:27:08 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-11-21 22:07:14 +0100
commit40e89f5be609045bc2666cc16a4ef80bb7f84095 (patch)
tree47084000b24535d138ef16a73aaa23c248bc65d7
parent9a87aa814a30a0f224633ad9770da69c1767a069 (diff)
downloadguix-40e89f5be609045bc2666cc16a4ef80bb7f84095.tar.gz
gnu: guix: Disable test that fails on Btrfs.
Works around <https://bugs.gnu.org/29363>.
Reported by Rutger Helling <rhelling@mykolab.com>.

* gnu/packages/package-management.scm (guix)[arguments]: Rename
'disable-container-tests' phase to 'disable-failing-tests' and add
substitution to disable test for freed disk space.
-rw-r--r--gnu/packages/package-management.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 4f1f7f577d..0c7aef9a5d 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -169,8 +169,7 @@
                         (copy "armhf")
                         (copy "aarch64")
                         #t))
-                    (add-after
-                        'unpack 'disable-container-tests
+                    (add-after 'unpack 'disable-failing-tests
                       ;; XXX FIXME: These tests fail within the build container.
                       (lambda _
                         (substitute* "tests/syscalls.scm"
@@ -183,6 +182,12 @@
                           (substitute* "tests/guix-environment-container.sh"
                             (("guix environment --version")
                              "exit 77\n")))
+                        ;; XXX: On some file systems (notably Btrfs), the test
+                        ;; for freed disk space after GC may fail.  See
+                        ;; <https://bugs.gnu.org/29363>.
+                        (substitute* "tests/store.scm"
+                          (("(\\(> freed 0\\))" all)
+                           (string-append ";" all)))
                         #t))
                     (add-before 'check 'set-SHELL
                       (lambda _