summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-07-18 21:16:06 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-01 19:23:08 +0800
commit423d5964eb62cc8992f0b9c59016253e4d5bea42 (patch)
tree51afc7dea9da23043d54735c41c9ab437e559793
parenta0d305005e8286fbfae084a99d981b8c21edea24 (diff)
downloadguix-423d5964eb62cc8992f0b9c59016253e4d5bea42.tar.gz
gnu: cagebreak: Update to 2.2.0, install man pages.
* gnu/packages/wm.scm (cagebreak): Update to 2.2.0.
[arguments]: Add '-Dman-pages=true' to configure-flags.
[native-inputs]: Replace pandoc with scdoc.
-rw-r--r--gnu/packages/wm.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index f2c050408e..8cc1f43e38 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2838,7 +2838,7 @@ shows a notification for the user on the screen.")
 (define-public cagebreak
   (package
     (name "cagebreak")
-    (version "2.1.2")
+    (version "2.2.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -2847,11 +2847,11 @@ shows a notification for the user on the screen.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "09ky8wili3ym8qi4dasckdcdcvn4g6ak08dg0yccnwmnlwxiyps6"))))
+                "0yhn77hdy7c80hd6r8nmvs206pmp76bx4zr94imfvgs8fh5gb8cy"))))
     (build-system meson-build-system)
     (arguments
      (list
-      #:configure-flags #~(list "-Dxwayland=true")
+      #:configure-flags #~(list "-Dxwayland=true" "-Dman-pages=true")
       ;; XXX: Running cagebreak tests need more tools, such as: clang-format,
       ;; shellcheck, git, gnupg ...
       #:tests? #f
@@ -2862,7 +2862,7 @@ shows a notification for the user on the screen.")
               (substitute* '("cagebreak.c" "meson.build")
                 (("/etc/") (string-append #$output "/etc/"))
                 (("/usr/share/") (string-append #$output "/usr/share/"))))))))
-    (native-inputs (list pandoc pkg-config))
+    (native-inputs (list pkg-config scdoc))
     (inputs (list libevdev pango wlroots))
     (home-page "https://github.com/project-repo/cagebreak")
     (synopsis "Tiling wayland compositor inspired by ratpoison")