summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-11-19 23:28:20 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-12-18 22:16:57 +0100
commit426e629e0c5829b0ac8987660c38eeb121f55675 (patch)
treec05e446199a3001bceb22f7e46c28e3da3b3aff0
parentd6fa189eefabdfdd4cca955b98b7b90f0cc07c75 (diff)
downloadguix-426e629e0c5829b0ac8987660c38eeb121f55675.tar.gz
gnu: ocaml-camomile: Use dune-build-system.
* gnu/packages/ocaml.scm (ocaml-camomile): Use dune-build-system.
-rw-r--r--gnu/packages/ocaml.scm18
1 files changed, 3 insertions, 15 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a776266dff..927c1ed8ff 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4403,23 +4403,11 @@ the plugins facilitate extensibility, and the frontends serve as entry points.")
               (sha256
                (base32
                 "01ssjrqz41jvrqh27jxnh9cx7ywi9b5sgsykd00i7z9nrcwhlfy2"))))
-    (build-system ocaml-build-system)
+    (build-system dune-build-system)
     (native-inputs
-     `(("camlp4" ,camlp4)
-       ("dune" ,dune)))
+     `(("camlp4" ,camlp4)))
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (delete 'configure)
-         (replace 'build
-           (lambda _
-             (invoke "dune" "build" "@install" "--profile" "release")
-             #t))
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (invoke "dune" "install"
-                     "--prefix" (assoc-ref outputs "out"))
-             #t)))
+     `(#:build-flags (list "--profile" "realease")
        #:tests? #f))
     (synopsis "Comprehensive Unicode library")
     (description "Camomile is a Unicode library for OCaml.  Camomile provides