summary refs log tree commit diff
diff options
context:
space:
mode:
authorMekeor Melire <mekeor.melire@gmail.com>2017-03-06 20:07:45 +0100
committerKei Kebreau <kei@openmailbox.org>2017-03-07 00:29:14 -0500
commit45321beb7d6cc92ff20ef1811bcc8119bb822ed9 (patch)
treeef252a3c5bc24f893516bd99c5ce8289a5356174
parent909de139e7f6ab474e6e510a3c15bb4b4731b8cf (diff)
downloadguix-45321beb7d6cc92ff20ef1811bcc8119bb822ed9.tar.gz
gnu: surf: Add 'dmenu' and 'xprop' to 'inputs'.
'dmenu' and 'xprop' are necessary to open a new URL in surf.

* gnu/packages/suckless.scm (surf)[inputs]: Add dmenu and xprop.
[arguments]: Add 'set-dmenu-and-xprop-file-name' phase to patch the
paths to the 'dmenu' and 'xprop' binaries in surf's configuration file.

Signed-off-by: Kei Kebreau <kei@openmailbox.org>
-rw-r--r--gnu/packages/suckless.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index e30a0883a3..80a02e1718 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -255,11 +255,20 @@ drawing.")
                           (string-append "PREFIX=" %output))
        #:phases
        (modify-phases %standard-phases
-         (delete 'configure))))
+         (delete 'configure)
+         ;; Use the right file name for dmenu and xprop.
+         (add-before 'build 'set-dmenu-and-xprop-file-name
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "config.def.h"
+               (("dmenu") (string-append (assoc-ref inputs "dmenu") "/bin/dmenu"))
+               (("xprop") (string-append (assoc-ref inputs "xprop") "/bin/xprop")))
+             #t)))))
     (inputs
-     `(("glib-networking" ,glib-networking)
+     `(("dmenu" ,dmenu)
+       ("glib-networking" ,glib-networking)
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
-       ("webkitgtk" ,webkitgtk/gtk+-2)))
+       ("webkitgtk" ,webkitgtk/gtk+-2)
+       ("xprop" ,xprop)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (home-page "http://surf.suckless.org/")