summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-04-20 00:18:31 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-04-20 17:43:10 +0200
commit46cb089f3182ac48481811dc14d668f07c70550c (patch)
tree9c6058fdc99a630a66b25cbd4c8b49e91b44307f
parent9a14cd7f354f9d48e9231be03023b3f68b53ae21 (diff)
downloadguix-46cb089f3182ac48481811dc14d668f07c70550c.tar.gz
gnu: python-nbxmpp: Update to 0.5.5.
* gnu/packages/messaging.scm (python-nbxmpp): Update to 0.5.5.
[source]: Use PYPI-URI.
[home-page]: Use HTTPS.
[description]: Fix up.
-rw-r--r--gnu/packages/messaging.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index cbb4d4eaba..59e2b23d32 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -434,24 +434,23 @@ simultaneously and therefore appear under the same nickname on IRC.")
 (define-public python-nbxmpp
   (package
     (name "python-nbxmpp")
-    (version "0.5.3")
+    (version "0.5.5")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "https://pypi.python.org/packages/source/n/nbxmpp/"
-                           "nbxmpp-" version ".tar.gz"))
+       (uri (pypi-uri "nbxmpp" version))
        (sha256
         (base32
-         "0dcr786dyips1fdvgsn8yvpgcz5j7217fi05c29cfypdl8jnp6mp"))))
+         "1gnzrzrdl4nii1sc5x8p5iw2ya5sl70j3nn34abqsny51p2pzmv6"))))
     (build-system python-build-system)
-    ;; No tests included
-    (arguments `(#:tests? #f))
-    (home-page "http://python-nbxmpp.gajim.org")
+    (arguments
+     `(#:tests? #f))                    ; no tests
+    (home-page "https://dev.gajim.org/gajim/python-nbxmpp")
     (synopsis "Non-blocking Jabber/XMPP module")
     (description
      "The goal of this python library is to provide a way for Python
 applications to use Jabber/XMPP networks in a non-blocking way.  This library
-was initially a fork of xmpppy, but is using non-blocking sockets.")
+was initially a fork of xmpppy, but uses non-blocking sockets.")
     (license license:gpl3+)))
 
 (define-public python2-nbxmpp