summary refs log tree commit diff
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2019-01-14 09:04:23 +0100
committerRutger Helling <rhelling@mykolab.com>2019-01-14 09:08:04 +0100
commit478040d4fb383d372ba17c83f54bbb2d24c6c372 (patch)
treeb893b64f18995aba8e45ca1bffe8cb795ee2a911
parent72b308364f9b84b9de36a1b7e96615cb3daa1f58 (diff)
downloadguix-478040d4fb383d372ba17c83f54bbb2d24c6c372.tar.gz
gnu: dosbox: Update to 0.74-2.
* gnu/packages/emulators.scm (dosbox): Update to 0.74-2.
[arguments]: Use invoke in 'autogen.sh phase.
-rw-r--r--gnu/packages/emulators.scm21
1 files changed, 9 insertions, 12 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 2d21f1246a..06c1a63b8d 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -8,7 +8,7 @@
 ;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017, 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -237,26 +237,23 @@ turbo speed, networked multiplayer, and graphical enhancements.")
 (define-public dosbox
   (package
     (name "dosbox")
-    (version "0.74.svn3947")
+    (version "0.74-2")
     (source (origin
-              (method svn-fetch)
-              (uri (svn-reference
-                    (url "http://svn.code.sf.net/p/dosbox/code-0/dosbox/trunk/")
-                    (revision 3947)))
-              (file-name (string-append name "-" version "-checkout"))
-              ;; Use SVN head, since the last release (2010) is incompatible
-              ;; with GCC 4.8+ (see
-              ;; <https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=624976>).
+              (method url-fetch)
+              (uri (string-append "https://sourceforge.net/projects/dosbox"
+                                  "/files/dosbox/" version "/dosbox-"
+                                  version ".tar.gz/download"))
+              (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "1p918j6090d1nkvgq7ifvmn506zrdmyi32y7p3ms40d5ssqjg8fj"))))
+                "1ksp1b5szi0vy4x55rm3j1y9wq5mlslpy8llpg87rpdyjlsk0xvh"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (add-after
                    'unpack 'autogen.sh
                    (lambda _
-                     (zero? (system* "sh" "autogen.sh")))))))
+                     (invoke "sh" "autogen.sh"))))))
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)))