summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-08-06 01:48:24 -0400
committerLeo Famulari <leo@famulari.name>2018-08-07 16:51:57 -0400
commit485638cd76f9c2cd35f8bd3e3c4ad03b337ce803 (patch)
tree18f8d4a57d205c4f3bcb80099798450c485596b4
parent800051266948521ab33283afae14ddd27611c5f3 (diff)
downloadguix-485638cd76f9c2cd35f8bd3e3c4ad03b337ce803.tar.gz
gnu: Add vidstab.
* gnu/packages/video.scm (vidstab): New variable.
-rw-r--r--gnu/packages/video.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 605e461a6c..042711f7aa 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3034,3 +3034,27 @@ project, which is released into the public domain, as well as ISO 14496-12:2005
 online.")
     (home-page "https://github.com/danielgtaylor/qtfaststart")
     (license license:expat)))
+
+(define-public vidstab
+  (package
+    (name "vidstab")
+    (version "1.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/georgmartius/vid.stab/"
+                                  "archive/v" version ".tar.gz"))
+              (sha256
+               (base32
+                "1fy03n343djfdi19msac81833v5iivpv635yjzrx9nkfwm9s1lhl"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:tests? #f)) ; tests are not run as part of standard build process
+    (home-page "http://public.hronopik.de/vid.stab/")
+    (synopsis "Video stabilization library")
+    (description "Vidstab is a video stabilization library which can be used
+with FFmpeg.  A video acquired using a hand-held camera or a camera mounted on a
+vehicle typically suffers from undesirable shakes and jitters.  Activities such
+as surfing, skiing, riding and walking while shooting videos are especially
+prone to erratic camera shakes.  Vidstab targets these video contents to help
+create smoother and stable videos.")
+    (license license:gpl2+)))