summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-16 01:00:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-16 01:00:02 +0100
commit487613deea9ccad60142a9494d43f5ec97089934 (patch)
tree4ac3fe0a2f12b37fe10e312fe9d6f2b1753a5dea
parenta2350a16dd2d7e465e63224d0b6a3dc421ab238e (diff)
downloadguix-487613deea9ccad60142a9494d43f5ec97089934.tar.gz
gnu: oil: Use G-expressions.
* gnu/packages/shells.scm (oil)[arguments]:
Rewrite as G-expressions.
-rw-r--r--gnu/packages/shells.scm39
1 files changed, 19 insertions, 20 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index a0c74ff286..52f675ea1d 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -838,26 +838,25 @@ Shell (pdksh).")
         (base32 "01lmj4diqpla1gwwb1gh1shf4y74qhanpkzcsnb28458rxm1sq32"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:strip-binaries? #f             ; strip breaks the binary
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'configure
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (setenv "CC" ,(cc-for-target))
-               (substitute* "configure"
-                 ((" cc ") " $CC "))
-               (invoke "./configure" (string-append "--prefix=" out)
-                       "--with-readline"))))
-         (replace 'check
-           ;; The tests are not distributed in the tarballs but upstream
-           ;; recommends running this smoke test.
-           ;; https://github.com/oilshell/oil/blob/release/0.8.0/INSTALL.txt#L38-L48
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (let* ((oil "_bin/oil.ovm"))
-                 (invoke/quiet oil "osh" "-c" "echo hi")
-                 (invoke/quiet oil "osh" "-n" "configure"))))))))
+     (list #:strip-binaries? #f         ; strip breaks the binary
+           #:phases
+           #~(modify-phases %standard-phases
+               (replace 'configure
+                 (lambda _
+                   (setenv "CC" #$(cc-for-target))
+                   (substitute* "configure"
+                     ((" cc ") " $CC "))
+                   (invoke "./configure" (string-append "--prefix=" #$output)
+                           "--with-readline")))
+               (replace 'check
+                 ;; The tests are not distributed in the tarballs but upstream
+                 ;; recommends running this smoke test.
+                 ;; https://github.com/oilshell/oil/blob/release/0.8.0/INSTALL.txt#L38-L48
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     (let* ((oil "_bin/oil.ovm"))
+                       (invoke/quiet oil "osh" "-c" "echo hi")
+                       (invoke/quiet oil "osh" "-n" "configure"))))))))
     (inputs
      (list readline))
     (home-page "https://www.oilshell.org")