summary refs log tree commit diff
diff options
context:
space:
mode:
authorraid5atemyhomework via Guix-patches via <guix-patches@gnu.org>2021-03-11 12:56:48 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2021-03-11 18:06:55 +0100
commit495a68e8e53b5f72c370c8a58a3ec5df892b17cb (patch)
tree99882739e1a053af8cf3c5c48decca053f2c1d6c
parent828b4a9156cb4b4914416185738b884034217370 (diff)
downloadguix-495a68e8e53b5f72c370c8a58a3ec5df892b17cb.tar.gz
gnu: Update zfs to 2.0.4.
Mostly FreeBSD fixes, some documentation changes and corrections, and a few small bugfixes.

Tested with `guix build` only, no in-depth testing done.

From 6037ac6f797f37abb579278a0d30cd16e6876ec6 Mon Sep 17 00:00:00 2001
From: raid5atemyhomework <raid5atemyhomework@protonmail.com>
Date: Thu, 11 Mar 2021 12:43:58 +0000
Subject: [PATCH] gnu: Update zfs to 2.0.4.

* gnu/packages/file-systems.scm (zfs): Update to 2.0.4, rename to
OpenZFS.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
-rw-r--r--gnu/packages/file-systems.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 18d7aaffce..a6c7969638 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -849,7 +849,7 @@ APFS.")
 (define-public zfs
   (package
     (name "zfs")
-    (version "2.0.3")
+    (version "2.0.4")
     (outputs '("out" "module" "src"))
     (source
       (origin
@@ -858,7 +858,7 @@ APFS.")
                               "/download/zfs-" version
                               "/zfs-" version ".tar.gz"))
           (sha256
-           (base32 "0fg5hz1yy2z5ah0hzjv3xy5vcg1c214rps90dr80lfkalx5gd506"))))
+           (base32 "0v2zshimz5miyj8mbskb52pnzyl1s4rhpr6208zq549v8g2l84vx"))))
     (build-system linux-module-build-system)
     (arguments
      `(;; The ZFS kernel module should not be downloaded since the license
@@ -968,9 +968,9 @@ APFS.")
        ("util-linux:lib" ,util-linux "lib")
        ("zlib" ,zlib)))
     (home-page "https://zfsonlinux.org/")
-    (synopsis "Native ZFS on Linux")
+    (synopsis "OpenZFS on Linux")
     (description
-     "ZFS on Linux is an advanced file system and volume manager which was
+     "OpenZFS is an advanced file system and volume manager which was
 originally developed for Solaris and is now maintained by the OpenZFS
 community.")
     (license license:cddl1.0)))