summary refs log tree commit diff
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2015-11-05 19:47:57 +0300
committerAlex Kost <alezost@gmail.com>2015-11-06 22:20:53 +0300
commit4c60ce4a6beea4be6cc1a9aecc28f73ccb338597 (patch)
treec92a7a88a0caf51ee06428170ffb6808d2e0f1fa
parentb9f1f3e2aac9ea8243ea2ec1499b0e060c435a0d (diff)
downloadguix-4c60ce4a6beea4be6cc1a9aecc28f73ccb338597.tar.gz
gnu: msmtp: Update to 1.6.2.
* gnu/packages/mail.scm (msmtp): Update to 1.6.2.
  [arguments]: Use '--with-tls' configure flag instead of
  '--with-ssl' (deprecated).
-rw-r--r--gnu/packages/mail.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 7f7a8e308a..b27eed8bfe 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -561,14 +561,14 @@ which can add many functionalities to the base client.")
 (define-public msmtp
   (package
     (name "msmtp")
-    (version "1.4.32")
+    (version "1.6.2")
     (source
      (origin
        (method url-fetch)
        (uri (string-append
-             "mirror://sourceforge/msmtp/msmtp-" version ".tar.bz2"))
+             "mirror://sourceforge/msmtp/msmtp-" version ".tar.xz"))
        (sha256 (base32
-                "122z38pv4q03w3mbnhrhg4w85a51258sfdg2ips0b6cgwz3wbw1b"))))
+                "12c7ljahb06pgn8yvvw526xvr11vnr6d4nr0apylixddpxycsvig"))))
     (build-system gnu-build-system)
     (inputs
      `(("libidn" ,libidn)
@@ -581,7 +581,7 @@ which can add many functionalities to the base client.")
     (arguments
      `(#:configure-flags (list "--with-libgsasl"
                                "--with-libidn"
-                               "--with-ssl=gnutls")))
+                               "--with-tls=gnutls")))
     (synopsis
      "Simple and easy to use SMTP client with decent sendmail compatibility")
     (description