summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 13:13:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:20 +0200
commit4d9b241d45dc7e81de9740b080160c3f9e00a774 (patch)
treec5d692ec3e7e5e08aeaa5ef74dcba7d9877e2b44
parent0f5f2120a2a4513263029253dcac17a71d5ddbae (diff)
downloadguix-4d9b241d45dc7e81de9740b080160c3f9e00a774.tar.gz
gnu: Add texlive-chemschemex.
* gnu/packages/tex.scm (texlive-chemschemex): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6e8e81cb4b..1049c7d62c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2423,6 +2423,26 @@ to draw process units and streams.  The guiding light of the package is the
 UNICHIM regulation.")
     (license license:lppl1.3c)))
 
+(define-public texlive-chemschemex
+  (package
+    (name "texlive-chemschemex")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/chemschemex/"
+                   "source/latex/chemschemex/"
+                   "tex/latex/chemschemex/")
+             (base32
+              "09mjxj1gwddbpkriivn8x98z9hls4pcmpdqf24a7gz19whgs1qyk")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/chemschemex")
+    (synopsis "Typeset and cross-reference chemical schemes based on TikZ code")
+    (description
+     "The package provides a comfortable means of typesetting chemical
+schemes, and also offers automatic structure referencing.")
+    (license license:lppl1.2+)))
+
 (define-public texlive-chronosys
   (package
     (name "texlive-chronosys")