summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-11-09 10:36:14 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-11-09 11:34:08 +0200
commit4dcd19d3ff143e7ef5ed1584a9ace65c348d1dfa (patch)
treea657087e072b2ec7f88266e6515eb1275c6455a1
parentfa82adb5e0e613037eb0377f318b7fa1423bdeba (diff)
downloadguix-4dcd19d3ff143e7ef5ed1584a9ace65c348d1dfa.tar.gz
gnu: macs: Update check phase.
* gnu/packages/bioinformatics.scm (macs)[arguments]: Don't delete 'check
phase before using custom 'check phase.
-rw-r--r--gnu/packages/bioinformatics.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a456b2b12c..010742b37b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4480,11 +4480,12 @@ experiments.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (delete 'check)
-         (add-after 'install 'check
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (add-installed-pythonpath inputs outputs)
-             (invoke "pytest" "-v"))))))
+         (replace 'check
+           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "pytest" "-v"))
+             #t)))))
     (inputs
      `(("python-numpy" ,python-numpy)))
     (native-inputs