summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-05-22 18:34:22 +0200
committerLudovic Courtès <ludo@gnu.org>2020-05-22 18:49:50 +0200
commit50ea3135e0948a042cd3b899e970f6ade291a0c2 (patch)
treedd8afd6381ac4614cdc0ca696770a3fef500b460
parent21051eb79efece62d3bda495ce554239ae7bbde2 (diff)
downloadguix-50ea3135e0948a042cd3b899e970f6ade291a0c2.tar.gz
gnu: bash: Do not autoload (gcrypt hash).
Fixes <https://bugs.gnu.org/41457>.
Reported by Matias Jose Seco Baccanelli <matias_jose_seco@autoproduzioni.net>.

* gnu/packages/bash.scm: Avoid #:autoload for (gcrypt hash).  On Guile 2.2,
autoloading would bring it not only the 'port-sha256' binding (as on
3.0) but also the 'sha256' binding.  As a result, use of 'sha256' in the
'origin' form wouldn't match.
-rw-r--r--gnu/packages/bash.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index 311e07a944..3ba8a13e40 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -38,8 +38,11 @@
   #:use-module (guix store)
   #:use-module (guix build-system gnu)
   #:autoload   (guix gnupg) (gnupg-verify*)
-  #:autoload   (gcrypt hash) (port-sha256)
   #:autoload   (guix base32) (bytevector->nix-base32-string)
+
+  ;; See <https://bugs.gnu.org/41457> for why not #:autoload here.
+  #:use-module ((gcrypt hash) #:select (port-sha256))
+
   #:use-module (srfi srfi-1)
   #:use-module (srfi srfi-26)
   #:use-module (ice-9 format))