summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-31 19:27:42 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-31 20:32:50 +0200
commit5237aa444da9c6063a5b2a0865b22c1255d72864 (patch)
tree715007f96488b765c82cdc982f6dd025f98cd002
parentc1d3f5841db4ca53d938251acfda2c81d3557329 (diff)
downloadguix-5237aa444da9c6063a5b2a0865b22c1255d72864.tar.gz
gnu: rtmpdump: Update to 2.4.
* gnu/packages/networking.scm (rtmpdump): Update to 2.4.
[arguments]: Fix RUNPATH.
-rw-r--r--gnu/packages/networking.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index a4c33e582a..e80c192a50 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -259,20 +259,24 @@ GLib-based library, libnice, as well as GStreamer elements to use it.")
 (define-public rtmpdump
   (package
     (name "rtmpdump")
-    (version "2.3")
+    (version "2.4")
     (source
      (origin
-       (method url-fetch)
-       (uri
-        (string-append "https://rtmpdump.mplayerhq.hu/download/"
-                       name "-" version ".tgz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.ffmpeg.org/rtmpdump")
+             (commit "c28f1bab7822de97353849e7787b59e50bbb1428")))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "0b2b49a57kpz9gi8dx1x3cs8b0gjx8x0c89x0q96kkl2knlvff7g"))))
+        (base32 "1n3kdip83nvvs4sin30zpcdr5q711mqhq2lxrv5vgbc6lskpwzlj"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f                      ; No tests
+     `(#:tests? #f                      ; no tests
        #:make-flags
        (list
+        ;; The ‘validate-runpath’ phase fails to find librtmp.so.0.
+        (string-append "LDFLAGS=-Wl,-rpath="
+                       (assoc-ref %outputs "out") "/lib")
         (string-append "prefix=" (assoc-ref %outputs "out")))
        #:phases
        (modify-phases %standard-phases