summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-12-13 15:14:06 +0100
committerLudovic Courtès <ludo@gnu.org>2015-12-13 15:20:44 +0100
commit5568151f5b571346e8c1760a1e0be9d7fd01b665 (patch)
treef937d18e8ad0f9d67cd28999cc9e267727f2ebe5
parent70650c684aed96e7b7d42548ebb012f716554024 (diff)
downloadguix-5568151f5b571346e8c1760a1e0be9d7fd01b665.tar.gz
gnu: wireless-regdb: Build sequentially.
Fixes <http://bugs.gnu.org/22126>.
Reported by Mark H Weaver <mhw@netris.org>.

* gnu/packages/linux.scm (wireless-regdb)[source]: Add 'snippet'.
[arguments]: Add #:parallel-build?.
-rw-r--r--gnu/packages/linux.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 503f9c3368..ad3bd51554 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1759,11 +1759,21 @@ compliance.")
                     "wireless-regdb-" version ".tar.xz"))
               (sha256
                (base32
-                "0czi83k311fp27z42hxjm8vi88fsbc23mhavv96lkb4pmari0jjc"))))
+                "0czi83k311fp27z42hxjm8vi88fsbc23mhavv96lkb4pmari0jjc"))
+
+              ;; We're building 'regulatory.bin' by ourselves.
+              (snippet '(delete-file "regulatory.bin"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases (modify-phases %standard-phases
                   (delete 'configure))
+
+       ;; The 'all' target of the makefile depends on $(REGDB_CHANGED), which
+       ;; is computed and can be equal to 'maintainer-clean'; when that
+       ;; happens, we can end up deleting the 'regulatory.bin' file that we
+       ;; just built.  Thus, build things sequentially.
+       #:parallel-build? #f
+
        #:tests? #f                                ;no tests
        #:make-flags (let ((out (assoc-ref %outputs "out")))
                       (list (string-append "PREFIX=" out)