summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
commit56f954e30534559021d0b36b1dcda5633e5e6922 (patch)
tree7d1af542f198c34bb53c0bb2540bbb8a31567b88
parent62e917a0c6ae8f3ed9c16e288c9c6bccf13c3487 (diff)
downloadguix-56f954e30534559021d0b36b1dcda5633e5e6922.tar.gz
gnu: asunder: Update to 3.0.1.
* gnu/packages/cdrom.scm (asunder): Update to 3.0.1.
[arguments]: Add a new 'fix-tests phase.
-rw-r--r--gnu/packages/cdrom.scm44
1 files changed, 26 insertions, 18 deletions
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index c0fecc9fdc..130fffc127 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -734,33 +734,41 @@ information is written to standard error.")
 (define-public asunder
   (package
     (name "asunder")
-    (version "2.9.7")
+    (version "3.0.1")
     (source
      (origin
        (method url-fetch)
        (uri
-        (string-append "http://www.littlesvr.ca/asunder/releases/asunder-"
+        (string-append "https://www.littlesvr.ca/asunder/releases/asunder-"
                        version ".tar.bz2"))
        (sha256
-        (base32 "1x3l308ss0iqhz90qyjb94gyd8b4piyrm2nzjmg5kf049k9prjf1"))))
+        (base32 "0srpag9bca76iiv8766kxmbvhsri58k15xp70348frkvp7hy4s48"))))
     (build-system glib-or-gtk-build-system)
     (arguments
      '(#:out-of-source? #f
-       #:phases (modify-phases %standard-phases
-                  (add-after 'install 'wrap
-                    (lambda* (#:key inputs outputs #:allow-other-keys)
-                      (let ((program (string-append (assoc-ref outputs "out")
-                                                    "/bin/asunder")))
-                        (define (bin-directory input-name)
-                          (string-append (assoc-ref inputs input-name) "/bin"))
-                        (wrap-program program
-                          `("PATH" ":" prefix
-                            ,(map bin-directory (list "cdparanoia"
-                                                      "lame"
-                                                      "vorbis-tools"
-                                                      "flac"
-                                                      "opus-tools"
-                                                      "wavpack"))))))))))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'fix-tests
+           ;; As of 3.0.1, there are no ‘real’ tests under src/, and the linty
+           ;; test under po/ is broken.  Still, it's trivial to fix.
+           (lambda _
+             (let ((file (open-file "po/POTFILES.in" "a")))
+               (format file "~%src/upload.c~%")
+               (close-port file))))
+         (add-after 'install 'wrap
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((program (string-append (assoc-ref outputs "out")
+                                           "/bin/asunder")))
+               (define (bin-directory input-name)
+                 (string-append (assoc-ref inputs input-name) "/bin"))
+               (wrap-program program
+                 `("PATH" ":" prefix
+                   ,(map bin-directory (list "cdparanoia"
+                                             "lame"
+                                             "vorbis-tools"
+                                             "flac"
+                                             "opus-tools"
+                                             "wavpack"))))))))))
     (native-inputs (list intltool pkg-config))
     ;; TODO: Add the necessary packages for Musepack encoding.
     (inputs `(("gtk+-2" ,gtk+-2)