summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-24 00:05:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-24 00:12:06 +0200
commit577e348c0bfdab1009299947f307a6be3961ab4a (patch)
tree53edfa9f9b158bfc6e01ed6bb7763f7eba08f484
parent9ed3ee95bdd03302229bbfe9fdd33af928c065c2 (diff)
downloadguix-577e348c0bfdab1009299947f307a6be3961ab4a.tar.gz
gnu: s6: Update to 2.11.0.0.
* gnu/packages/skarnet.scm (s6): Update to 2.11.0.0.
[arguments]: Don't explicitly return #t from phases.
-rw-r--r--gnu/packages/skarnet.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/skarnet.scm b/gnu/packages/skarnet.scm
index c9bc4c6323..6cff495c8c 100644
--- a/gnu/packages/skarnet.scm
+++ b/gnu/packages/skarnet.scm
@@ -103,14 +103,14 @@ complexity.")))
 (define-public s6
   (package
    (name "s6")
-   (version "2.10.0.3")
+   (version "2.11.0.0")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "https://skarnet.org/software/s6/s6-"
                          version ".tar.gz"))
      (sha256
-      (base32 "0mw7blp8dwr09z58m9mrxwmmvvpnjzq9klcf1vgm0hbha4qkf88x"))))
+      (base32 "1a3lj0xfhn1w3a4ygqsxy8q4dr3n48hnwml4xzdpz3nrikhy8if5"))))
    (build-system gnu-build-system)
    (inputs `(("skalibs" ,skalibs)
              ("execline" ,execline)))
@@ -132,8 +132,7 @@ complexity.")))
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
                    (doc (string-append out "/share/doc/s6-" ,version)))
-              (copy-recursively "doc" doc)
-              #t))))))
+              (copy-recursively "doc" doc)))))))
    (home-page "https://skarnet.org/software/s6")
    (license isc)
    (synopsis "Small suite of programs for process supervision")