summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-27 20:15:08 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-27 20:40:17 +0200
commit57dac1ee935edfab91e9b182c1f7c9ddae794656 (patch)
treedeae6c89155011b49c478004e86afdc0d136a7a0
parenta1d3874293fb210250cbd9b39e1b49b71b1c06b0 (diff)
downloadguix-57dac1ee935edfab91e9b182c1f7c9ddae794656.tar.gz
gnu: python-cairocffi: Update to 0.9.0.
* gnu/packages/python.scm (python-cairocffi): Update to 0.9.0.
[source](uri): Use PYPI-URI.
[native-inputs]: Add PYTHON-PYTEST-COV and PYTHON-PYTEST-RUNNER.
[arguments]: Remove #:tests? and outdated comment.
-rw-r--r--gnu/packages/python.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fc22ebfb2b..15f6d33121 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4078,17 +4078,14 @@ support for Python 3 and PyPy.  It is based on cffi.")
 (define-public python-cairocffi
   (package
     (name "python-cairocffi")
-    (version "0.8.0")
+    (version "0.9.0")
     (source
      (origin
       (method url-fetch)
-      ;; The archive on pypi is missing the 'utils' directory!
-      (uri (string-append "https://github.com/Kozea/cairocffi/archive/v"
-                          version ".tar.gz"))
-      (file-name (string-append name "-" version ".tar.gz"))
+      (uri (pypi-uri "cairocffi" version))
       (sha256
        (base32
-        "1rk2dvy3fxrga6bvvxc2fi5lbaynm5h4a0w0aaxyn3bc77rszjg9"))
+        "0dq3k4zhqd8cwsf3nyjqvjqm8wkvrjn1wjf44rl3v0h8kqx6qf0m"))
       (patches (search-patches "python-cairocffi-dlopen-path.patch"))))
     (build-system python-build-system)
     (outputs '("out" "doc"))
@@ -4101,14 +4098,14 @@ support for Python 3 and PyPy.  It is based on cffi.")
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-pytest-runner" ,python-pytest-runner)
        ("python-sphinx" ,python-sphinx)
        ("python-docutils" ,python-docutils)))
     (propagated-inputs
      `(("python-xcffib" ,python-xcffib))) ; used at run time
     (arguments
-     `(;; FIXME: Tests cannot find 'libcairo.so.2'.
-       #:tests? #t
-       #:phases
+     `(#:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-paths
            (lambda* (#:key inputs outputs #:allow-other-keys)