summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-08-01 14:10:47 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-02 09:20:40 +0300
commit5aceacac65784bd2e1fd12304f965ae6026de49d (patch)
tree4993aca11ff62efb9e330be597948a9fa9893359
parent635e20aae904263418fb2939de355ba1ca111672 (diff)
downloadguix-5aceacac65784bd2e1fd12304f965ae6026de49d.tar.gz
gnu: mesa: Update skipped tests on powerpc-linux.
* gnu/packages/gl.scm (mesa)[arguments]: When building for powerpc-linux
adjust the 'disable-failing-test phase for changes in failed tests.
-rw-r--r--gnu/packages/gl.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 2f7c25bc57..b53b42a9ba 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -408,15 +408,11 @@ svga,swrast,virgl")))
                                    ;; This is probably a big-endian test failure.
                                    "src/gallium/targets/osmesa/meson.build")
                       (("if with_tests") "if not with_tests"))
-                    (substitute* "src/util/tests/format/meson.build"
-                      ;; This is definately an endian-ness test failure.
-                      (("'u_format_test', ") ""))
-                    ;; It is only this portion of the test which fails.
-                    (substitute* "src/mesa/main/tests/meson.build"
-                      ((".*mesa_formats.*") ""))
                     ;; This test times out and receives SIGTERM.
                     (substitute* "src/amd/common/meson.build"
-                      (("and not with_platform_windows") "and with_platform_windows"))))
+                      (("and not with_platform_windows") "and with_platform_windows"))
+                    (substitute* "src/compiler/nir/meson.build"
+                      ((".*loop_unroll_tests.*") ""))))
                  ("i686-linux"
                   ;; This test is known to fail on i686 (see:
                   ;; https://gitlab.freedesktop.org/mesa/mesa/-/issues/4091).