summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-02 00:22:09 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-02 15:52:54 +0100
commit5c0f68e84491b03332e0f070f43c54effac3c64f (patch)
tree38e16ee180bc70ae6510c8e0a8277e4db1d6d3ce
parentf136c8f23d6dc0b52540456d50187f3417afb5e3 (diff)
downloadguix-5c0f68e84491b03332e0f070f43c54effac3c64f.tar.gz
gnu: fossil: Update phase style.
* gnu/packages/version-control.scm (fossil)[arguments]: Substitute
INVOKE for SYSTEM* and end phases with #t.
-rw-r--r--gnu/packages/version-control.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 6c05ab59db..05f50869a3 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1643,14 +1643,15 @@ repository\" with git-annex.")
        #:phases (modify-phases %standard-phases
                   (replace 'configure
                     (lambda* (#:key outputs (configure-flags '())
-                                    #:allow-other-keys)
+                              #:allow-other-keys)
                       ;; The 'configure' script is not an autoconf script and
                       ;; chokes on unrecognized options.
-                      (zero? (apply system*
-                                    "./configure"
-                                    (string-append "--prefix="
-                                                   (assoc-ref outputs "out"))
-                                    configure-flags))))
+                      (apply invoke
+                             "./configure"
+                             (string-append "--prefix="
+                                            (assoc-ref outputs "out"))
+                             configure-flags)
+                      #t))
                   (add-before 'check 'test-setup
                     (lambda _
                       (setenv "USER" "guix")