summary refs log tree commit diff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-07-29 21:57:51 +1000
committerBen Woodcroft <donttrustben@gmail.com>2018-07-29 21:58:00 +1000
commit5d5a02dd4c036d790c209bc235a5702488f3cc33 (patch)
tree918eed348e770b566a226831a33f2cb9936bb8f5
parent10d53153613f97731a32a85077db6e0a4f2baa98 (diff)
downloadguix-5d5a02dd4c036d790c209bc235a5702488f3cc33.tar.gz
gnu: Add python-fastalite.
* gnu/packages/bioinformatics.scm (python-fastalite, python2-fastalite):
New variables.
-rw-r--r--gnu/packages/bioinformatics.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e87cef61be..4d84b90f1e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -767,6 +767,29 @@ into separate processes; and more.")
 (define-public python2-biopython
   (package-with-python2 python-biopython))
 
+(define-public python-fastalite
+  (package
+    (name "python-fastalite")
+    (version "0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "fastalite" version))
+       (sha256
+        (base32
+         "1qli6pxp77i9xn2wfciq2zaxhl82bdxb33cpzqzj1z25yd036wqj"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f)) ; Test data is not distributed.
+    (home-page "https://github.com/nhoffman/fastalite")
+    (synopsis "Simplest possible FASTA parser")
+    (description "This library implements a FASTA and a FASTQ parser without
+relying on a complex dependency tree.")
+    (license license:expat)))
+
+(define-public python2-fastalite
+  (package-with-python2 python-fastalite))
+
 (define-public bpp-core
   ;; The last release was in 2014 and the recommended way to install from source
   ;; is to clone the git repository, so we do this.