summary refs log tree commit diff
diff options
context:
space:
mode:
authorhumanitiesNerd <catonano@gmail.com>2017-03-20 21:10:58 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-03-21 12:55:47 +0100
commit6330ece9e35ac9d582330a92d5a61b493e28f507 (patch)
tree0a57e8bb2bc157561bf512d3fa22349310e47baf
parent2b9d2df799919014e9f989416589bb83eeccccad (diff)
downloadguix-6330ece9e35ac9d582330a92d5a61b493e28f507.tar.gz
gnu: Add perl-ole-storage-lite.
* gnu/packages/perl.scm (perl-ole-storage-lite): New variable.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 04b9fa2862..086e1fae03 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5178,6 +5178,29 @@ inherit from in order to allow your objects to generate unique cryptographic
 signatures.")
     (license (package-license perl))))
 
+(define-public perl-ole-storage-lite
+  (package
+    (name "perl-ole-storage-lite")
+    (version "0.19")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/J/JM/JMCNAMARA/OLE-Storage_Lite-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "179cxwqxb0f9dpx8954nvwjmggxxi5ndnang41yav1dx6mf0abp7"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/OLE-Storage_Lite")
+    (synopsis "Read and write OLE storage files")
+    (description "This module allows you to read and write
+an OLE-Structured file.  @dfn{OLE} (Object Linking and Embedding) is a
+technology to store hierarchical information such as links to other
+documents within a single file.")
+    (license (package-license perl))))
+
 (define-public perl-package-anon
   (package
     (name "perl-package-anon")