summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-15 15:48:18 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-15 22:02:54 +0100
commit6388bed78cf6e9126b53e2a2ef832765a0373ab7 (patch)
treed7c2b1033d9f49a94a80bf240c257b5b70e94169
parent4a894c2f096d39ef3a412576c120f0e6d09806d5 (diff)
downloadguix-6388bed78cf6e9126b53e2a2ef832765a0373ab7.tar.gz
gnu: efivar: Remove obsolete workaround.
* gnu/packages/linux.scm (efivar)[arguments]: Remove phase
'kernel-headers-are-system-headers'.
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 1 insertions, 8 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7793bf4d7c..2bf7b4bee9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5062,14 +5062,7 @@ under OpenGL graphics workloads.")
                           (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
        #:phases
        (modify-phases %standard-phases
-         (delete 'configure)
-         (add-before 'build 'kernel-headers-are-system-headers
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((kernel-headers (assoc-ref inputs "kernel-headers")))
-               ;; Make sure the kernel headers are treated as system headers
-               ;; to suppress a conflict between "util.h" and <linux/fs.h>.
-             (setenv "C_INCLUDE_PATH" (string-append kernel-headers "/include"))
-             #t))))))
+         (delete 'configure))))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs