summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-11-17 22:34:30 +0100
committerLudovic Courtès <ludo@gnu.org>2019-11-17 23:14:54 +0100
commit65209ffabd9245fac78eeb2caf5bcca3e4963937 (patch)
treefce4e2ccf080428242042fb9437a26cb647abcb2
parentbead6dcb58f8e3f907ae4421e42b9e5e26bb2c24 (diff)
downloadguix-65209ffabd9245fac78eeb2caf5bcca3e4963937.tar.gz
gnu: gsettings-desktop-schemas: Fix file name of default background.
Reported by Alexandros Theodotou <alex@zrythm.org>
at <https://lists.gnu.org/archive/html/guix-devel/2019-11/msg00157.html>.

* gnu/packages/gnome.scm (gsettings-desktop-schemas)[arguments]: New
field.
[inputs]: Add GNOME-BACKGROUNDS.
-rw-r--r--gnu/packages/gnome.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f9126d18e1..d8545eaa58 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -861,8 +861,21 @@ on the GNOME Desktop with a single simple application.")
        (base32
         "0bshwm49cd01ighsxqlbqn10q0ch71ff99gcrx8pr2gyky2ad3pq"))))
     (build-system gnu-build-system)
+    (arguments
+     '(#:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'set-adwaita-theme-file-name
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      ;; Provide the correct file name of the default GNOME
+                      ;; background, 'adwaita-timed.xml'.
+                      (let ((theme (assoc-ref inputs "gnome-backgrounds")))
+                        (substitute* (find-files "schemas"
+                                                 "\\.gschema\\.xml\\.in$")
+                          (("@datadir@/backgrounds/gnome")
+                           (string-append theme "/share/backgrounds/gnome")))
+                        #t))))))
     (inputs
-     `(("glib" ,glib)))
+     `(("glib" ,glib)
+       ("gnome-backgrounds" ,gnome-backgrounds)))
     (native-inputs
      `(("intltool" ,intltool)
        ("glib" ,glib "bin")                       ; glib-compile-schemas, etc.