summary refs log tree commit diff
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-05-02 11:17:22 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-02 15:14:44 +0200
commit67b10f18c725fdc8859c224d6a2a02ef06f2414c (patch)
tree00a1a7fd0f8d221009473efb2d5afc594c991e62
parentfe6ba5e9025da736aec0e18ac610dc548df52a5e (diff)
downloadguix-67b10f18c725fdc8859c224d6a2a02ef06f2414c.tar.gz
gnu: apl: Use G-expressions.
* gnu/packages/apl.scm (apl)[arguments]: Use G-expressions.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/apl.scm33
1 files changed, 17 insertions, 16 deletions
diff --git a/gnu/packages/apl.scm b/gnu/packages/apl.scm
index 0a741b0295..e483876cc5 100644
--- a/gnu/packages/apl.scm
+++ b/gnu/packages/apl.scm
@@ -23,6 +23,7 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix git-download)
   #:use-module (guix svn-download)
+  #:use-module (guix gexp)
   #:use-module (guix packages)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages gettext)
@@ -54,22 +55,22 @@
              readline
              sqlite))
       (arguments
-       `(#:configure-flags (list (string-append
-                                  "--with-sqlite3="
-                                  (assoc-ref %build-inputs "sqlite")))
-         #:phases
-         (modify-phases %standard-phases
-           (add-before 'configure 'fix-configure
-             (lambda _
-               (substitute* "buildtag.sh"
-                 ;; Don't exit on failed SVN-related calls.
-                 (("^ +return 0\n") "")
-                 ;; Manually set the SVN revision, since the directory is
-                 ;; unversioned and we know it anyway.
-                 (("^SVNINFO=.*")
-                  ,(string-append "SVNINFO=" (number->string revision) "\n"))
-                 ;; Requires running ‘svn info’ on a versioned directory.
-                 (("\\\\\"\\$ARCHIVE_SVNINFO\\\\\"") "\\\"\\\"")))))))
+       (list #:configure-flags #~(list (string-append
+                                        "--with-sqlite3="
+                                        #$(this-package-input "sqlite")))
+             #:phases
+             #~(modify-phases %standard-phases
+                 (add-before 'configure 'fix-configure
+                   (lambda _
+                     (substitute* "buildtag.sh"
+                       ;; Don't exit on failed SVN-related calls.
+                       (("^ +return 0\n") "")
+                       ;; Manually set the SVN revision, since the directory is
+                       ;; unversioned and we know it anyway.
+                       (("^SVNINFO=.*")
+                        (string-append "SVNINFO=" #$(number->string revision) "\n"))
+                       ;; Requires running ‘svn info’ on a versioned directory.
+                       (("\\\\\"\\$ARCHIVE_SVNINFO\\\\\"") "\\\"\\\"")))))))
       (synopsis "APL interpreter")
       (description
        "GNU APL is a free interpreter for the programming language APL.  It is