summary refs log tree commit diff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2021-03-27 07:27:52 -0400
committerMark H Weaver <mhw@netris.org>2021-03-27 19:48:43 -0400
commit69437a59e67634f85477a5eadab092598aa57ee1 (patch)
tree5ef706f09407895d2ae2b01231cfd652a40fe54f
parentbe3aef49ed1d8a0f13d64cd5cf6f280500876efd (diff)
downloadguix-69437a59e67634f85477a5eadab092598aa57ee1.tar.gz
gnu: dblatex: Add 'dblatex/stable' variant.
* gnu/packages/docbook.scm (dblatex/stable): New variable.
-rw-r--r--gnu/packages/docbook.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 012e86f6a5..e348fb1a5b 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -33,6 +34,7 @@
   #:use-module (guix licenses)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module ((guix build utils) #:select (alist-replace))
   #:use-module (guix build-system trivial)
   #:use-module (guix build-system python))
 
@@ -460,3 +462,14 @@ process.  MathML 2.0 markups are supported too.  It started as a clone of
 DB2LaTeX.")
     ;; lib/contrib/which is under an X11 license
     (license gpl2+)))
+
+;; This is a variant of the 'dblatex' package that is not updated often.  It
+;; is intended to be used as a native-input at build-time only, e.g. by
+;; 'gtk-doc' for generating package documentation.  This allows the main
+;; 'dblatex' and 'imagemagick' packages to be freely updated on the 'master'
+;; branch without triggering an excessive number of rebuilds.
+(define-public dblatex/stable
+  (hidden-package
+   (package/inherit dblatex
+     (inputs (alist-replace "imagemagick" `(,imagemagick/stable)
+                            (package-inputs dblatex))))))