summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-09-01 10:55:48 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:22 +0200
commit6a006a11fde6be270b2d35a9570544c9c70bb967 (patch)
treeb4bd646f66d7159175bc02ac80af703b459c5703
parentf548cd7254b696249a185972a55ff18dd0616b34 (diff)
downloadguix-6a006a11fde6be270b2d35a9570544c9c70bb967.tar.gz
gnu: ghc-pandoc: Adjust tests and test dependency constraints.
* gnu/packages/haskell.scm (ghc-pandoc)[arguments]: Add a phase to relax a
test suite dependency constraint and another to skip some failing tests.
-rw-r--r--gnu/packages/haskell.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index bcdb6fb609..8b2c157a71 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6859,6 +6859,20 @@ provided.  Skylighting is intended to be the successor to highlighting-kate.")
         (base32
          "1dqin92w513l7whg5wdgrngnxsj5mb8gppfvn7kjgyv2pdgpy0zy"))))
     (build-system haskell-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'update-constraints
+           (lambda _
+             (substitute* "pandoc.cabal"
+               (("tasty >= 0\\.11 && < 1\\.1")
+                "tasty >= 0.11 && < 1.1.1"))))
+         (add-before 'configure 'patch-tests
+           (lambda _
+             ;; These tests fail benignly and have been adjusted upstream:
+             ;; <https://github.com/commercialhaskell/stackage/issues/3719>.
+             (substitute* "test/Tests/Old.hs"
+               (("lhsWriterTests \"html\"") "[]")))))))
     (inputs
      `(("ghc-aeson" ,ghc-aeson)
        ("ghc-aeson-pretty" ,ghc-aeson-pretty)