summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-11-03 10:33:32 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-11-03 10:34:24 +0100
commit6b968c4cd390734e91edf251731b094e99c1fa55 (patch)
treeef0d6d9467f54fbf71d13324762e40a004b00ec7
parent81e0b62502e928f2a1b3e9370241a1d881ac7766 (diff)
downloadguix-6b968c4cd390734e91edf251731b094e99c1fa55.tar.gz
gnu: Add r-corrplot.
* gnu/packages/cran.scm (r-corrplot): New variable.
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 03356cb6fd..04af03d95b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1267,3 +1267,25 @@ for certain use cases.")
 avoid overlapping text labels.  Labels repel away from each other and away
 from the data points.")
     (license license:gpl3)))
+
+(define-public r-corrplot
+  (package
+    (name "r-corrplot")
+    (version "0.84")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "corrplot" version))
+       (sha256
+        (base32
+         "1k03qd8db7pwg1v318xapx5mpiypiz2n07qr19c4b45diri5xkhd"))))
+    (build-system r-build-system)
+    (home-page "https://github.com/taiyun/corrplot")
+    (synopsis "Visualization of a correlation matrix")
+    (description
+     "This package provides a graphical display of a correlation matrix or
+general matrix.  It also contains some algorithms to do matrix reordering.  In
+addition, corrplot is good at details, including choosing color, text labels,
+color labels, layout, etc.")
+    ;; Any version of the GPL
+    (license license:gpl2+)))