summary refs log tree commit diff
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2018-07-08 18:56:10 +0200
committerLudovic Courtès <ludo@gnu.org>2018-07-09 17:01:59 +0200
commit6c123c2666f423433a256ccdd954fb3470c29a84 (patch)
tree4edd4a6d3de7bf640863b75707a515c078a794b4
parentaf7914a1f135c3286b51fa6214a59b5b0329cbec (diff)
downloadguix-6c123c2666f423433a256ccdd954fb3470c29a84.tar.gz
gnu: Add emacs-nodejs-repl.
* gnu/packges/emacs.scm (emacs-nodejs-repl): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 9f055cfc51..9bd4114559 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4182,6 +4182,32 @@ errors and strict-mode warnings, smart line-wrapping within comments and
 strings, and code folding.")
     (license license:gpl3+)))
 
+(define-public emacs-nodejs-repl
+  (package
+    (name "emacs-nodejs-repl")
+    (version "0.1.6")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/abicky/nodejs-repl.el"
+                                  "/archive/" version ".tar.gz"))
+              (sha256
+               (base32
+                "0sphg1jxi3a5l0gqdp27d0qgyjaiq2p293av9zm8ksm0vwqp3fr9"))
+              (file-name (string-append name "-" version ".tar.gz"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/abicky/nodejs-repl.el")
+    (synopsis "Node.js REPL inside Emacs")
+    (description
+     "This program is derived from comint-mode and provides the following
+features:
+
+@itemize
+@item TAB completion same as Node.js REPL
+@item file name completion in string
+@item incremental history search
+@end itemize")
+    (license license:gpl3+)))
+
 (define-public emacs-markdown-mode
   (package
     (name "emacs-markdown-mode")