summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-06-07 03:34:05 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-06-07 18:36:02 +0200
commit6d42b87f1d6909d3bfdcbd00cae0d2b03e799eb1 (patch)
treeb7cced1d3221c603a553d0b10c99171aab069b55
parent7f5c1233b923192b820d3fc01c94a024947a6a0f (diff)
downloadguix-6d42b87f1d6909d3bfdcbd00cae0d2b03e799eb1.tar.gz
gnu: dashel: Don't use unstable tarball.
* gnu/packages/cpp.scm (dashel)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
[home-page]: Move down to its conventional spot.
-rw-r--r--gnu/packages/cpp.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 14a8fa87e7..9e95bacd65 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -108,17 +108,19 @@ operating system functions.")
   (package
     (name "dashel")
     (version "1.3.3")
-    (home-page "https://github.com/aseba-community/dashel")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append home-page "/archive/" version ".tar.gz"))
-              (sha256
-               (base32
-                "1ckzac1rsw3cxmpdpwcqv46jyp7risk5ybq6jjiizbqn7labf6dw"))
-              (file-name (string-append name "-" version ".tar.gz"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/aseba-community/dashel.git")
+             (commit version)))
+       (sha256
+        (base32 "0anks2l2i2qp0wlzqck1qgpq15a3l6dg8lw2h8s4nsj7f61lffwy"))
+       (file-name (git-file-name name version))))
     (build-system cmake-build-system)
-    (arguments '(#:tests? #f))                    ;no tests
+    (arguments '(#:tests? #f))          ; no tests
     (native-inputs `(("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/aseba-community/dashel")
     (synopsis "Data stream helper encapsulation library")
     (description
      "Dashel is a data stream helper encapsulation C++ library.  It provides a