summary refs log tree commit diff
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2020-07-13 04:15:28 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-10-14 00:51:09 +0200
commit6e085d6f17e831e88a35c275892bde32fdb11986 (patch)
tree31632bda4dc0f29094e32fc9aa23f3827c309032
parent939680f3354b0266292a1d947879f6fe0ad5b3ae (diff)
downloadguix-6e085d6f17e831e88a35c275892bde32fdb11986.tar.gz
gnu: Add go-github-com-arceliar-phony.
* gnu/packages/golang.scm (go-github-com-arceliar-phony): New variable.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 35665223ef..c908a52453 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5738,3 +5738,28 @@ Included are the following:
 except that it adds convenience functions that use the fmt package to format
 error messages.")
     (license license:bsd-3)))
+
+(define-public go-github-com-arceliar-phony
+  (let ((commit "d0c68492aca0bd4b5c5c8e0452c9b4c8af923eaf")
+        (revision "0"))
+    (package
+      (name "go-github-com-arceliar-phony")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/Arceliar/phony")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0876y0hlb1zh8hn0pxrb5zfdadvaqmqwlr66p19yl2a76galz992"))))
+      (arguments
+       '(#:import-path "github.com/Arceliar/phony"))
+      (build-system go-build-system)
+      (home-page "https://github.com/Arceliar/phony")
+      (synopsis "Very minimal actor model library")
+      (description "Phony is a very minimal actor model library for Go,
+inspired by the causal messaging system in the Pony programming language.")
+      (license license:expat))))