summary refs log tree commit diff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-07-26 23:30:14 -0400
committerKei Kebreau <kkebreau@posteo.net>2018-07-26 23:35:45 -0400
commit6e92fba4b0bf6d7d608ef0368642ff1341b07696 (patch)
tree3ebffa942cb051dc9fa22716e6d61c6f9aa248e8
parentd36b98ad951f051d18a58ffd30ad59f2f571034c (diff)
downloadguix-6e92fba4b0bf6d7d608ef0368642ff1341b07696.tar.gz
gnu: python-xsge: Update to 2018.02.26.
* gnu/packages/game-development.scm (python-xsge, python2-xsge): Update to
2018.02.26.
[arguments]: Substitute invoke for system*.
-rw-r--r--gnu/packages/game-development.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 33e2b4a16c..03841c9b46 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -357,14 +357,14 @@ levels.")
 (define-public python-xsge
   (package
     (name "python-xsge")
-    (version "2017.06.09")
+    (version "2018.02.26")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://savannah/xsge/xsge/xsge-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "1vy7c2y7ihvmggs93zgfv2h3049s384wid8a5snzrrba8bhbb89p"))))
+                "0bx93hgf7cgdw2gsygbh59y8vpw37pgsa279rajw3fkdpl8vrc40"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
@@ -373,10 +373,9 @@ levels.")
          ;; system's default flags, "--single-version-externally-managed".
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
-             (zero?
-              (system* "python" "setup.py" "install"
-                       (string-append "--prefix=" (assoc-ref outputs "out"))
-                       "--root=/")))))
+             (invoke "python" "setup.py" "install"
+                     (string-append "--prefix=" (assoc-ref outputs "out"))
+                     "--root=/"))))
        #:tests? #f)) ; no check target
     (propagated-inputs
      `(("python-sge-pygame" ,python-sge-pygame)