summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:51:32 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:28 +0200
commit704bde84ec27383773f0b941c56664b44f3553dc (patch)
tree4e80f462977860dea82ab4334d57ad047dba2a91
parent36a240a6c1ac8c2d4522036bcf5b26f5e2c16030 (diff)
downloadguix-704bde84ec27383773f0b941c56664b44f3553dc.tar.gz
gnu: Add texlive-structmech.
* gnu/packages/tex.scm (texlive-structmech): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c3c983b8dd..e6935edd2d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6413,6 +6413,27 @@ the popular @code{amsmath} package.")
 numbers in the Steinmetz notation used in electrotechnics.")
     (license license:lppl)))
 
+(define-public texlive-structmech
+  (package
+    (name "texlive-structmech")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/structmech/"
+                   "tex/latex/structmech/")
+             (base32
+              "1xh9qwwk3fgdwaz5bb0w2yyv0li9vsdpfyx0r6hg694vf99ym6mb")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/structmech")
+    (synopsis "TikZ command set for structural mechanics drawings")
+    (description
+     "This package provides a collection of TikZ commands that allow users to
+draw basic elements in material/structural mechanics.  It is thus possible to
+draw member forces, nodal forces/displacements, various boundary conditions,
+internal force distributions, etc.")
+    (license license:gpl3+)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")