summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2018-09-30 20:33:46 +0800
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:23 +0200
commit70fa5899af8a2270c29e40035e6258865a4f4461 (patch)
treed52c82f1ed73a3fc694f83443e8716297ee113bd
parenteaa1f873e69c64e5d7f7535e95f6ae0be75c3ac9 (diff)
downloadguix-70fa5899af8a2270c29e40035e6258865a4f4461.tar.gz
gnu: ghc-wave: Fix build.
* gnu/packages/haskell.scm (ghc-wave)[arguments]: Add a phase to relax
dependency constraints.
-rw-r--r--gnu/packages/haskell.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index df0190d591..4a915142c1 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8338,6 +8338,14 @@ Rust syntax.  It is intended to be useful for two different purposes:
         (base32
           "03zycmwrchhqvi37fdvlzz2d1vl4hy0i8xyys1zznw38qfq0h2i5"))))
     (build-system haskell-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'update-constraints
+           (lambda _
+             (substitute* "wave.cabal"
+               (("temporary.* < 1\\.3")
+                "temporary >= 1.1 && < 1.4")))))))
     (inputs
      `(("ghc-cereal" ,ghc-cereal)
        ("ghc-data-default-class"