summary refs log tree commit diff
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2017-04-07 21:18:55 +0800
committerLudovic Courtès <ludo@gnu.org>2017-04-08 15:32:23 +0200
commit72fa66674d17bdf6acef87665295e604c56c15e9 (patch)
tree7e177a6a1345f1b0d0fb29f45c7f084f40c4f3ca
parent181170c6ee871d4410a5ffabd4bc517a1d5cbc80 (diff)
downloadguix-72fa66674d17bdf6acef87665295e604c56c15e9.tar.gz
gnu: Add you-get.
* gnu/packages/video.scm (you-get): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/video.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 4f005f5940..bb5391d89e 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -14,6 +14,7 @@
 ;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
 ;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2017 Feng Shu <tumashu@163.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1023,6 +1024,31 @@ YouTube.com and a few more sites.")
     (home-page "https://yt-dl.org")
     (license license:public-domain)))
 
+(define-public you-get
+  (package
+    (name "you-get")
+    (version "0.4.652")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/soimort/you-get/releases/download/v"
+                    version "/you-get-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0brkz98lycx8mmxjwmn7jlhqfdbvl0hy070n7skwr1k75kh99q30"))))
+    (build-system python-build-system)
+    (arguments
+     ;; no tests
+     '(#:tests? #f))
+    (inputs
+     `(("ffmpeg" ,ffmpeg)))
+    (synopsis "Download videos, audios, or images from Web sites")
+    (description
+     "You-Get is a command-line utility to download media contents (videos,
+audio, images) from the Web.  It can use either mpv or vlc for playback.")
+    (home-page "https://you-get.org/")
+    (license license:expat)))
+
 (define-public libbluray
   (package
     (name "libbluray")