summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-03-19 21:55:27 -0400
committerArun Isaac <arunisaac@systemreboot.net>2018-04-14 20:13:30 +0530
commit74b4d7a142193ea6006268139c79a1e68f0e9fb1 (patch)
tree9049440429b2657e4b9e5368d6929f3d202e6104
parentfee23c17a9792e0463f10fbde837ab9bde3b7a03 (diff)
downloadguix-74b4d7a142193ea6006268139c79a1e68f0e9fb1.tar.gz
gnu: emacs-polymode: Fix byte compilation.
* gnu/packages/emacs.scm (emacs-polymode)[arguments]: Add modes subdirectory
to #:include. Add add-modes-subdir-to-load-path phase.

Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
-rw-r--r--gnu/packages/emacs.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index def4ab1129..fa05b983db 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -7041,6 +7041,15 @@ contexts.
                  (base32
                   "057cybkq3cy07n5s332k071sjiky3mziy003lza4rh75mgqkwhmh"))))
       (build-system emacs-build-system)
+      (arguments
+       `(#:include (cons* "^modes/.*\\.el$" %default-include)
+         #:phases
+         (modify-phases %standard-phases
+           (add-after 'set-emacs-load-path 'add-modes-subdir-to-load-path
+             (lambda _
+               (setenv "EMACSLOADPATH"
+                       (string-append (getenv "EMACSLOADPATH")
+                                      ":" (getcwd) "/modes" ":")))))))
       (home-page "https://github.com/vspinu/polymode")
       (synopsis "Framework for multiple Emacs modes based on indirect buffers")
       (description "Polymode is an Emacs package that offers generic support