summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-12-23 19:17:17 +0100
committerLudovic Courtès <ludo@gnu.org>2014-12-23 19:17:17 +0100
commit764c077b307f0a9cdc800494da552077d6d23895 (patch)
treebd52955c8a40ee7b2b09c1cbbad7e1ae12983f5d
parent78a274537032bdd61a11845ac0cf48cb121e8458 (diff)
downloadguix-764c077b307f0a9cdc800494da552077d6d23895.tar.gz
Revert "gnu: matplotlib: Comment out python2-matplotlib."
This reverts commit afc720d34c43a2fcf0b5871226c15ad6c5f73697.
-rw-r--r--gnu/packages/python.scm72
1 files changed, 36 insertions, 36 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2ff258fb4b..f81ab695af 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2011,17 +2011,17 @@ capabilities.")
                                 (find-files "." ".*"))))))
               ,phases)))))))
 
-;; (define-public python2-numpy
-;;   (let ((numpy (package-with-python2 python-numpy)))
-;;     (package (inherit numpy)
-;;       ;; Make sure we use exactly PYTHON2-NUMPYDOC, which is customized for
-;;       ;; Python 2. Since it is also an input to PYTHON2-MATPLOTLIB, we need to
-;;       ;; import the right version of 'matplotlib' as well.
-;;       (inputs `(("python2-numpydoc" ,python2-numpydoc)
-;;                 ("python2-matplotlib" ,python2-matplotlib)
-;;                 ,@(alist-delete "python-numpydoc" 
-;;                                 (alist-delete "python-matplotlib"
-;;                                               (package-inputs numpy))))))))
+(define-public python2-numpy
+  (let ((numpy (package-with-python2 python-numpy)))
+    (package (inherit numpy)
+      ;; Make sure we use exactly PYTHON2-NUMPYDOC, which is customized for
+      ;; Python 2. Since it is also an input to PYTHON2-MATPLOTLIB, we need to
+      ;; import the right version of 'matplotlib' as well.
+      (inputs `(("python2-numpydoc" ,python2-numpydoc)
+                ("python2-matplotlib" ,python2-matplotlib)
+                ,@(alist-delete "python-numpydoc" 
+                                (alist-delete "python-matplotlib"
+                                              (package-inputs numpy))))))))
 
 (define-public python-pyparsing
   (package
@@ -2227,22 +2227,22 @@ ipython shell, web application servers, and six graphical user interface
 toolkits.")
     (license psfl)))
 
-;; (define-public python2-matplotlib
-;;   (let ((matplotlib (package-with-python2 python-matplotlib)))
-;;     (package (inherit matplotlib)
-;;       ;; Make sure we use exactly PYTHON2-NUMPYDOC, which is
-;;       ;; customized for Python 2.
-;;       (propagated-inputs 
-;;        `(("python2-py2cairo" ,python2-py2cairo)
-;;          ("python2-pygobject-2" ,python2-pygobject-2)
-;;          ,@(alist-delete "python-pycairo"
-;;                          (alist-delete "python-pygobject"
-;;                                        (package-propagated-inputs 
-;;                                         matplotlib)))))
-;;       (inputs 
-;;        `(("python2-numpydoc" ,python2-numpydoc)
-;;          ,@(alist-delete "python-numpydoc" 
-;;                          (package-inputs matplotlib)))))))
+(define-public python2-matplotlib
+  (let ((matplotlib (package-with-python2 python-matplotlib)))
+    (package (inherit matplotlib)
+      ;; Make sure we use exactly PYTHON2-NUMPYDOC, which is
+      ;; customized for Python 2.
+      (propagated-inputs 
+       `(("python2-py2cairo" ,python2-py2cairo)
+         ("python2-pygobject-2" ,python2-pygobject-2)
+         ,@(alist-delete "python-pycairo"
+                         (alist-delete "python-pygobject"
+                                       (package-propagated-inputs 
+                                        matplotlib)))))
+      (inputs 
+       `(("python2-numpydoc" ,python2-numpydoc)
+         ,@(alist-delete "python-numpydoc" 
+                         (package-inputs matplotlib)))))))
 
 ;; Scipy 0.14.0 with Numpy 0.19.X fails several tests.  This is known and
 ;; planned to be fixed in 0.14.1.  It is claimed that the failures can safely
@@ -2341,15 +2341,15 @@ the SciPy stack.  It provides many user-friendly and efficient numerical
 routines such as routines for numerical integration and optimization.")
     (license bsd-3)))
 
-;; (define-public python2-scipy
-;;   (let ((scipy (package-with-python2 python-scipy)))
-;;     (package (inherit scipy)
-;;       ;; Use packages customized for python-2.
-;;       (inputs `(("python2-matplotlib" ,python2-matplotlib)
-;;                 ("python2-numpy" ,python2-numpy)
-;;                 ,@(alist-delete "python-matplotlib" 
-;;                                 (alist-delete "python-numpy" 
-;;                                               (package-inputs scipy))))))))
+(define-public python2-scipy
+  (let ((scipy (package-with-python2 python-scipy)))
+    (package (inherit scipy)
+      ;; Use packages customized for python-2.
+      (inputs `(("python2-matplotlib" ,python2-matplotlib)
+                ("python2-numpy" ,python2-numpy)
+                ,@(alist-delete "python-matplotlib" 
+                                (alist-delete "python-numpy" 
+                                              (package-inputs scipy))))))))
 
 (define-public python-sqlalchemy
   (package