summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-07-11 11:19:37 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-07-11 11:19:37 +0200
commit77504dddae496bb11cdf240b3ed10ee9964391e5 (patch)
tree50a3a0927e3090bd06135c01667e1adb13dc453a
parent157139612a34660679f827996f781a605cb1bed5 (diff)
downloadguix-77504dddae496bb11cdf240b3ed10ee9964391e5.tar.gz
gnu: emacs-doom-themes: Update package style.
* gnu/packages/emacs-xyz.scm (emacs-doom-themes)[arguments]: Use
G-expressions. Remove trailing #T at the end of a phase.
-rw-r--r--gnu/packages/emacs-xyz.scm35
1 files changed, 17 insertions, 18 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2dab2f40c6..9f79136bb6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -28027,24 +28027,23 @@ contrast and few colors.")
     (native-inputs
      (list emacs-ert-runner))
     (arguments
-     `(#:tests? #t
-       #:test-command '("ert-runner")
-       #:modules ((guix build emacs-build-system)
-                  (guix build utils)
-                  (guix build emacs-utils)
-                  (srfi srfi-1))
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'move-themes
-           (lambda _
-             ;; Move the source files to the top level, which is in the
-             ;; EMACSLOADPATH.
-             (for-each (lambda (f)
-                         (rename-file f (basename f)))
-                       (append
-                           (find-files "./themes" ".*\\.el$")
-                           (find-files "./extensions" ".*\\.el$")))
-             #t)))))
+     (list #:tests? #t
+           #:test-command #~(list "ert-runner")
+           #:modules '((guix build emacs-build-system)
+                       (guix build utils)
+                       (guix build emacs-utils)
+                       (srfi srfi-1))
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'move-themes
+                 (lambda _
+                   ;; Move the source files to the top level, which is in the
+                   ;; EMACSLOADPATH.
+                   (for-each (lambda (f)
+                               (rename-file f (basename f)))
+                             (append
+                                 (find-files "./themes" ".*\\.el$")
+                                 (find-files "./extensions" ".*\\.el$"))))))))
     (synopsis "Wide collection of color themes for Emacs")
     (description "Emacs-doom-themes contains numerous popular color themes for
 Emacs that integrate with major modes like Org-mode.")