summary refs log tree commit diff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-02-18 01:16:13 -0500
committerMathieu Othacehe <othacehe@gnu.org>2022-03-29 11:17:46 +0200
commit779acb0ba1067b27d9ae32d0e4f9ad525bcda213 (patch)
tree27b602b80f047fc516b0dccac5ffa65fed7a4a23
parentc116376542a8508dc90ed1ed12d27e92dfe73bc7 (diff)
downloadguix-779acb0ba1067b27d9ae32d0e4f9ad525bcda213.tar.gz
gnu: mercury: Remove trailing #T from phases and snippet.
* gnu/packages/mercury.scm (mercury)[arguments]<#:phases>: Remove trailing #T.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/mercury.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/mercury.scm b/gnu/packages/mercury.scm
index fe02b34a97..c87e65fdd1 100644
--- a/gnu/packages/mercury.scm
+++ b/gnu/packages/mercury.scm
@@ -100,8 +100,7 @@
                        (invoke "mv" orig-name new-name)
                        (with-directory-excursion new-name
                          (apply patch-source-shebangs (list #:source src)))))
-                    `((,libatomic-ops "source" "boehm_gc/libatomic_ops")))
-               #t)))
+                    `((,libatomic-ops "source" "boehm_gc/libatomic_ops"))))))
          (add-after 'replace-boehm-gc 'patch-paths
            (lambda _
              (substitute*
@@ -133,8 +132,7 @@
                        "boehm_gc/Makefile.direct")
                (("/bin/sh") (which "sh"))
                (("/bin/pwd") (which "pwd"))
-               (("/bin/rm") (which "rm")))
-             #t)))))
+               (("/bin/rm") (which "rm"))))))))
     (native-inputs
      `(("texinfo" ,texinfo)
        ("flex" ,flex)
@@ -227,12 +225,10 @@ separate compilation, and numerous optimization/time trade-offs.")
                         (("/bin/sh") (which "sh"))
                         (("/bin/pwd") (which "pwd"))
                         (("/bin/rm") (which "rm"))
-                        (("boehm_gc/.git") "boehm_gc"))
-                      #t))
+                        (("boehm_gc/.git") "boehm_gc"))))
                   (replace 'bootstrap
                     (lambda _
-                      (invoke "./prepare.sh")
-                      #t))))))
+                      (invoke "./prepare.sh")))))))
            ;; TODO: Uncomment phase when tests are enabled.
            ;; (replace 'check
            ;;   (lambda _