summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:58:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:33 +0200
commit78b0512f828758c594702adff2315317adbf66a9 (patch)
tree1ee879661b3613c9c12efdc75c278eace8e85d19
parentb4498e41ab8f3af9c9258bca9e70e85d4c1e2464 (diff)
downloadguix-78b0512f828758c594702adff2315317adbf66a9.tar.gz
gnu: Add texlive-tex-ewd.
* gnu/packages/tex.scm (texlive-tex-ewd): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1555324950..0759118d44 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6679,6 +6679,27 @@ with mixed upper and lower indices with spacing, also typeset preposed
 indices.")
     (license license:lppl)))
 
+(define-public texlive-tex-ewd
+  (package
+    (name "texlive-tex-ewd")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/tex-ewd/"
+                   "tex/generic/tex-ewd/")
+             (base32
+              "1xlxbnn16mf7mzz57rjzqqv18mcy0immmlcsnksda03dh7hn8b69")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/tex-ewd")
+    (synopsis
+     "Macros to typeset calculational proofs and programs in Dijkstra's style")
+    (description
+     "Edsger W. Dijkstra and others suggest a unique style to present
+mathematical proofs and to construct programs.  This package provides macros
+that support calculational proofs and Dijkstra's guarded command language.")
+    (license license:bsd-1)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")