summary refs log tree commit diff
diff options
context:
space:
mode:
authorGábor Boskovits <boskovits@gmail.com>2019-06-12 14:20:56 +0200
committerGábor Boskovits <boskovits@gmail.com>2019-06-16 00:29:00 +0200
commit7a1d6a770878fe5a45af8763559a86da0258b0f1 (patch)
tree35988cbbe4313102522f4c81a249fb4c9fddcf5b
parent121d9d1a7a2406a9b1cbe22c34343775f5955b34 (diff)
downloadguix-7a1d6a770878fe5a45af8763559a86da0258b0f1.tar.gz
gnu: Add waybar.
* gnu/packages/wm.scm(waybar): New variable.
-rw-r--r--gnu/packages/wm.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index d5344dc31d..5737fea8d9 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -20,6 +20,7 @@
 ;;; Copyright © 2018, 2019 Meiyo Peng <meiyo@riseup.net>
 ;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2019 Timothy Sample <samplet@ngyro.com>
+;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -85,6 +86,10 @@
   #:use-module (gnu packages version-control)
   #:use-module (gnu packages man)
   #:use-module (gnu packages textutils)
+  #:use-module (gnu packages pretty-print)
+  #:use-module (gnu packages logging)
+  #:use-module (gnu packages serialization)
+  #:use-module (gnu packages commencement) ; TODO remove when default gcc version >=7
   #:use-module (guix download)
   #:use-module (guix git-download))
 
@@ -1315,3 +1320,44 @@ modules for building a Wayland compositor.")
     (synopsis "Screen wallpaper utility for Wayland compositors")
     (description "Swaybg is a wallpaper utility for Wayland compositors.")
     (license license:expat))) ; MIT license
+
+(define-public waybar
+  (package
+    (name "waybar")
+    (version "0.6.8")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Alexays/Waybar.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0wyp1p9r1k8jnjq8clp2fx8xa3f4lfrgbp67fxrjh9718p4br0ab"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:configure-flags
+       (list (string-append "-Dout=" (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         ;; TODO remove when issue #30756 is resolved
+         (add-before 'configure 'fix-gcc
+           (lambda _
+             (unsetenv "C_INCLUDE_PATH")
+             (unsetenv "CPLUS_INCLUDE_PATH")
+             #t)))))
+    (inputs `(("fmt" ,fmt)
+              ("gtkmm" ,gtkmm)
+              ("jsoncpp" ,jsoncpp)
+              ("libinput" ,libinput)
+              ("spdlog" ,spdlog)
+              ("wayland" ,wayland)))
+    (native-inputs `(("gcc-toolchain" ,gcc-toolchain-7) ; TODO remove when default gcc version >=7
+                     ("glib:bin" ,glib "bin")
+                     ("pkg-config" ,pkg-config)
+                     ("wayland-protocols" ,wayland-protocols)))
+    (home-page "https://github.com/Alexays/Waybar")
+    (synopsis "Wayland bar for Sway and Wlroots based compositors.")
+    (description "Waybar is a highly customisable Wayland bar for Sway and
+Wlroots based compositors.")
+    (license license:expat))) ; MIT license